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Chapter 1:

Important:

Software Overview

The Import utility only works with SQL Server 2008, SQL Server 2008
Express, SQL Server 2005, and SQL Server 2005 Express.

The Import Utility is a 32-bit Windows application used to import ASCII
delimited text files into the B.A.S.I.S.® Access Control and ID CredentialCenter
badging system. This import utility only supports the addition of new records. No
update or delete capabilities are provided. If any records already exist with the
same social security number (if used), then the duplicate record will be skipped
and not imported.

Important:

Notes:

This utility is currently designed to import ASCII delimited files to a
Microsoft SQL Server or Microsoft SQL Server 2005 Express database
using ODBC.

This utility is for import only! There are no update or delete capabilities
whatsoever. If a social security or badge ID already exists in the database,
that row in the import file is skipped and NOT imported, leaving that record
unchanged.
The import utility requires that all the columns in the ASCII file be present
even if they are to be left blank.
The client’s ASCII delimited file must follow the sample ASCII delimited
file (sample.txt) EXACTLY! Almost all the data columns can be blank.
(For more information, refer to Required Fields on page 6.) HOWEVER, the
data must be in the order as described by the header in the sample ASCII
delimited file.
Some data columns cannot be blank - namely the Last Name data column.
If any badge information is provided (i.e. badge ID), they must provide a
Badge Type. Keep in mind that if badge information is provided, it is
recommended that the Activate, Deactivate, and Status columns are also
provided. However, if these are blank but Badge Type is not, the default
values for Activate, Deactivate, and Status are 01/01/1997, 01/01/2002,
and Active, respectively.

Formatting Your Import File
The Import Utility imports an ASCII delimited file into a B.A.S.I.S. database.
The import utility accepts only one import file format.
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Your Import Utility installation directory contains a sample ASCII delimited file,
sample.txt. By default, this is located in the DataX directory of the B.A.S.I.S.
installation path (C:\Program Files\B.A.S.I.S.\DataX). The sample.txt file
contains all of the fields that are imported into the B.A.S.I.S. database.

Important:

To import data into custom fields you must use DataExchange.

You will notice from the sample.txt file that an ASCII delimited file is simply an
ASCII (text) file, each row of which contains an employee record with badge and
access level information. Individual fields, such as First Name, Last Name, etc.,
are separated by a delimiter; hence the term “ASCII delimited.” In the sample.txt
file, the delimiter is a vertical bar character ( | ).
The format of your import file must match that of the sample.txt file
EXACTLY. Specifically, you cannot change the order in which the fields are
listed. However, just about any character can be used as the delimiter. You can
specify the delimiter from within the utility before importing the file. If, for
example, the “|” character is contained in one of your data fields, you must avoid
using “|” as your delimiter and choose another one. The delimiter you choose
MUST NOT appear anywhere in the data portion being imported.
The first row in the sample.txt file contains the field headings. This indicates the
order in which the fields are to be placed. You can import and view sample.txt in
Microsoft Excel and use the file as a template to easily format your own data.
Fields that you do not use or wish to ignore can simply be left blank (except
required fields). However, you must still separate the fields using the delimiter
character. Delimiters are the only way the Import Utility can distinguish one field
from another piece of information.
For example, in sample.txt, notice that in the second row (i.e., Maria Arquette’s
record) the phone number field (homephone) is represented by |425-6532|. If you
did not have a phone number for her, nothing would appear between the delimiter
characters, but they would still need to be maintained. Therefore, if the
homephone was unavailable the entry would be represented as ||.

Required Fields
Certain columns in the ASCII delimited import file are required. They are:
•

Last Name

•

Badge ID (unless using auto-increment file StdSQLAutoBadgeID.xdf)

•

Badge Type (name of badge type, i.e., Marketing, Engineering, Visitor, etc.)

Note:
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If you do not have any badge information, then leave all badge fields blank
and no badge record will be associated with the cardholder information.
•

Badge Activation date will default to 01/01/1997 if left blank and badge
information is entered.

•

Badge Deactivation date will default to 01/01/2002 if left blank and badge
information is entered.
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•

Badge Status will default to Active if left blank and badge information is
entered.

Running the Import Utility
Important:

Before you run the Import Utility, you must have already installed B.A.S.I.S.
software and confirmed that the software is running. Do not run the Import
Utility until your other B.A.S.I.S. software is installed and functioning
properly!

If your system is segmented, you cannot import badges with access levels that do not exist.
The access levels must already be entered into the system using the System
Administration application.

Warning

During the import process, make sure that none of the workstations on your
network adds, modifies, or deletes B.A.S.I.S. cardholder records or access levels!
To run the Import Utility:

Note:

1.

Start the Import Utility by clicking the Windows Start button, then selecting
to Program Files > B.A.S.I.S. ET693 > Import. When you click Import,
the Import Utility will open.

2.

You must have the ODBC driver installed on this workstation before
continuing. Check with your system administrator to confirm that you have
an ODBC data source to the B.A.S.I.S. database.

3.

From the File menu, select Open. Navigate to the DataX directory of the
B.A.S.I.S. installation path (C:\Program Files\B.A.S.I.S.\DataX by
default) and select the appropriate XDF import definition file based on the
following criteria:
•

Use StdSQLAutoBadgeID.xdf if you are using system assigned, autoincrementing badge ids

•

Use StdSQLManualBadgeID.xdf if the ASCII import file contains the
badge ID values

If you do not know how your system assigns badge IDs, you can check by
selecting the Administration > Cardholder Options menu option in the ID
CredentialCenter application. Click the Badge ID Allocation tab. The value
in the Generate Badge ID field is how the badge IDs are assigned.
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The following table summarizes the import definition file choices:

Import File Definition Choices
Database

System assigned
auto-incrementing
badge ID

User assigned badge ID

SQL Server 2008,
SQL Server
2008 Express,
SQL Server 2005,
SQL Server
2005 Express

StdSQLAutoBadgeID.xdf

StdSQLManualBadgeID.xdf

Note:

The name of the XDF file you have loaded is displayed in the title bar.

4.

In the Source Database/File section:
a.

In the Source Type field, verify that “Text File” is selected.

b.

Select whether the first row in the file you are importing has a header.

c.

Note:

Select the First Row Header check box if the file does have a
header. The sample.txt file is an example of a file with a header;
the first row contains column headings that you would not wish to
import as a record.

•

Do not select the First Row Header check box if the first line of
the file contains data you wish to have imported as a record.

If your ASCII delimited file uses a different delimiter other than what is
displayed in the Delimiter field, change the delimiter value to what
your import file is using.

Please note that the drop-down box in front of the Delimiter field contains
some standard delimiters. If yours is not in the list, select Other from the list
and enter your character in the box next to the drop down list. For example,
if you were to import from the sample file you would select Other and
specify |.

d.

5.
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•

Make sure that the File name field contains the full pathname to your
ASCII delimited import file. If it is not, you can click on the folder icon
to select the file.

In the Destination Database/File section:
a.

Make sure that the Destination Type field has “ODBC” selected.

b.

The Connect field should contain the appropriate ODBC connect string.
You can use the default ODBC connect string that is automatically
entered for you unless you have changed the password to SQL Server or
your ODBC data source name is not BEST. Make the necessary changes
to the connect string if your password or ODBC data source name is not
BEST.
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c.

In the ODBC Data Source To Use field, enter the name of the 32-bit
ODBC data source name (DSN) that is accessing the access control
system database in the ODBC. If you are not sure what your DSN is,
you can look in your ACS.INI file in your windows directory and
check. In the ACS.INI file you will find a key called “Connect” under
the [Database] section, which looks like the following:
Connect =“ODBC;DSN=BEST”. (In this case, the DSN is BEST.)

6.

Click the [Exchange Data] button.

7.

The Data XChange dialog should appear.

8.

Click the [Start] button to begin importing data. A dialog appears warning
that you should have valid data before importing.

9.

Click [Yes] at the dialog that warns you to have valid data before continuing
with the import.

10. The progress meters should begin moving and importing your data.
11. When the meters reach 100%, the import is complete. Click [Close].
12. If you made any changes to the Destination Database/File or Source
Database/File sections, and you wish to save them so you can reuse the
settings, click the File > Save menu option. The Select File name dialog
opens, and you can specify a new file name for your modified .XDF
definition file.
13. When you are ready to exit, simply click the File > Exit menu option and
click [Yes] at the confirmation prompt.

Pitfalls

Important:

•

Do NOT have multiple access levels with the same access level on a single
import row.

•

Make sure that no workstation on your network adds, modifies, or deletes
B.A.S.I.S. cardholder records or access levels during the import process!

•

Any data contained in a B.A.S.I.S. drop-down list field is automatically
added to the choices contained in that list, if it is not already in the B.A.S.I.S.
database. These refer to such items as the “dept” (i.e., department) and “loc”
(i.e., location) fields. For this reason, a misspelling in your data is a serious
hazard to your database integrity. Suppose, for example, that B.A.S.I.S.
currently has a department named “Engineering”, and that your import file
includes 100 records that each have “Enginering” (missing an “e”) in the
“dept” field. The misspelled “Enginering” will be added to the list of choices
in B.A.S.I.S. for department, and all of the 100 records will have the
incorrect choice selected. You will then need to manually change each of the
100 records to fix the problem!

•

If you receive an error [0] when attempting to open the ODBC connection to
import photos, you are probably using the wrong LNLCTL.DLL. This was
probably loaded by the imaging software.

Do not run the imaging software until the import is complete.
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•

To enable the [Field Links] button, place a “-c” option on the command line.
In the Import Module application, this button is displayed by selecting
Options > Access Field Links.

•

To specify a particular data exchange file from the command line, insert the
“-f” parameter followed immediately by the full pathname of the XDF file.

•

To bypass the initial main window containing the data definition source/
destination information, insert the “-z” parameter on the command line.
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